Vista Style Builder

   Home   Help Search Login Register  
Pages: [1] 2
  Print  
Author Topic: VSB 1.5 Released  (Read 38076 times)
AndreasV
Administrator
Dedicated Themer
*****
Posts: 158


View Profile
« on: October 18, 2009, 10:48:39 pm »

Version 1.5 of Vista Style Builder has just been released and focusses on full Windows 7 compatibility as well as new features. You can get this version thru the download link you received in your activation e-mail.

Changelog 1.5:

FIX: lastImageId is now set correctly by default, newly compiled themes will no longer crash when logging on
FIX: Fixed memory leak when opening a lot of themes
FIX: Searching is somewhat faster
FIX: STREAM/atlas generator works better for border cases resulting in smaller STREAMS for better system performance
FIX: One-time uxtheme patcher are now launched correctly
FIX: Windows 7 classes, parts and states are finalized (PandaX)
FIX: Vista to Windows 7 MsStyles converter has been fixed (PandaX)
FIX: Open-file dialogs not working should be fixed now (upgraded GUI library to new version)
FIX: editing RECT properties on Windows 7 should now work
FIX: "add property" and "remove property" buttons will no longer disappear
FIX: Missing icons on Windows 7

ADD: Integrated help/wiki system
ADD: tabs for multiple images
ADD: Option to Switch between Basic/Aero mode (shift+click = test in basic mode directly)
ADD: Search for colors in either r,g,b or #RRGGBB format
ADD: Search for colors in images
ADD: Window position is now retained when closing the application
ADD: Last opened file is opened by default
ADD: Image dimensions are displayed on the image preview
ADD: Shift+click on the edit button to change the image editor used
Logged
K-Johnson
Beta Tester
Dedicated Themer
*
Posts: 275



View Profile WWW
« Reply #1 on: October 18, 2009, 11:25:04 pm »

Wow, thanks for listening to the suggestions and polishing the program!
Logged
bhast2
Beta Tester
Dedicated Themer
*
Posts: 177



View Profile WWW
« Reply #2 on: October 18, 2009, 11:34:22 pm »

Awesome ok  i just downloaded it and I am still getting 1.4 from my download link in my email
« Last Edit: October 18, 2009, 11:39:06 pm by bhast2 » Logged
CoLnE
Beginner
*
Posts: 77


View Profile
« Reply #3 on: October 19, 2009, 12:04:32 am »

Version 1.5 of Vista Style Builder has just been released and focusses on full Windows 7 compatibility as well as new features. You can get this version thru the download link you received in your activation e-mail.

Changelog 1.5:

FIX: lastImageId is now set correctly by default, newly compiled themes will no longer crash when logging on
FIX: Fixed memory leak when opening a lot of themes
FIX: Searching is somewhat faster
FIX: STREAM/atlas generator works better for border cases resulting in smaller STREAMS for better system performance
FIX: One-time uxtheme patcher are now launched correctly
FIX: Windows 7 classes, parts and states are finalized (PandaX)
FIX: Vista to Windows 7 MsStyles converter has been fixed (PandaX)
FIX: Open-file dialogs not working should be fixed now (upgraded GUI library to new version)
FIX: editing RECT properties on Windows 7 should now work
FIX: "add property" and "remove property" buttons will no longer disappear
FIX: Missing icons on Windows 7

ADD: Integrated help/wiki system
ADD: tabs for multiple images
ADD: Option to Switch between Basic/Aero mode (shift+click = test in basic mode directly)
ADD: Search for colors in either r,g,b or #RRGGBB format
ADD: Search for colors in images
ADD: Window position is now retained when closing the application
ADD: Last opened file is opened by default
ADD: Image dimensions are displayed on the image preview
ADD: Shift+click on the edit button to change the image editor used


my email is bad_colne@yahoo.com and i didnt recieve any link to download it. its only for v1.4 Sad
Logged
bhast2
Beta Tester
Dedicated Themer
*
Posts: 177



View Profile WWW
« Reply #4 on: October 19, 2009, 12:14:47 am »

ok I cleared my cache and now I have 1.5
great release
Logged
AndreasV
Administrator
Dedicated Themer
*****
Posts: 158


View Profile
« Reply #5 on: October 19, 2009, 12:16:18 am »

New versions are available at the original download link . I've just double-checked the file and it is version 1.5 for me.
Logged
K-Johnson
Beta Tester
Dedicated Themer
*
Posts: 275



View Profile WWW
« Reply #6 on: October 19, 2009, 12:24:23 am »

I can also confirm that it is 1.5.
Logged
iJesse
Beginner
*
Posts: 71


View Profile
« Reply #7 on: October 19, 2009, 01:54:32 am »

 :'(Danget, I accidentally deleted my E-Mail  Cry
Logged
Spitzen
Beta Tester
Dedicated Themer
*
Posts: 200


Windows 7 Themer


View Profile WWW
« Reply #8 on: October 19, 2009, 02:19:20 am »

It's just awesome. Thank you Andreas Smiley
Logged
AndreasV
Administrator
Dedicated Themer
*****
Posts: 158


View Profile
« Reply #9 on: October 19, 2009, 03:27:24 am »

There was a small isue detected with the "Edit Image" button - it would always ask for a new image editor to be set.
This issue has been quickly corrected in 1.5.0.3 which can now be downloaded  Embarrassed Whoops!
Logged
Panda X
Administrator
Dedicated Helper
*****
Posts: 1627



View Profile
« Reply #10 on: October 19, 2009, 04:00:19 am »

By the way for those editing the Documentation you can link to other parts, classes, and states by creating a link like vsb://Taskbar & System Tray > TaskBand > Basic > TaskBand > TaskItemButton
Logged
AlbinoAsian
Beginner
*
Posts: 50


View Profile
« Reply #11 on: October 19, 2009, 10:09:29 am »

oh thanks in advance, about to download it now!

You guys rock!
Logged
koumy
Dedicated Themer
*
Posts: 223


View Profile
« Reply #12 on: October 19, 2009, 10:23:01 am »

Thanks for this update !

Have to relocate some items but overall good job and clearer  Smiley
Logged
AlbinoAsian
Beginner
*
Posts: 50


View Profile
« Reply #13 on: October 19, 2009, 10:26:26 am »

the search color in image function is an awesome addition
and the help is great too...
is it possible to search the help though?
Logged
AlbinoAsian
Beginner
*
Posts: 50


View Profile
« Reply #14 on: October 19, 2009, 10:38:56 am »

just added this as a news item to DeviantArt, http://news.deviantart.com/article/97092/
hope you don't mind.

Logged
rajtheeban
Beta Tester
Dedicated Themer
*
Posts: 192


View Profile WWW
« Reply #15 on: October 19, 2009, 11:46:56 am »



prachtig!

prachtig! dank u Andreas voor de nieuwe versie voor u en voor iedereen die dit project!
  Smiley
« Last Edit: October 19, 2009, 11:55:14 am by rajtheeban » Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2106



View Profile
« Reply #16 on: October 19, 2009, 02:19:17 pm »

I tried the new Color Search. As soon as I enter the first rgb value I get a screen asking me whether I want to search for that color in images too. I say yes and they show up. But I never get the chance to enter more than one value at a time, much less all 3 together.

Knowing me I'm likely missing something obvious. But I could use an explanation anyway. Thanks.
Logged
Spitzen
Beta Tester
Dedicated Themer
*
Posts: 200


Windows 7 Themer


View Profile WWW
« Reply #17 on: October 19, 2009, 02:58:23 pm »

Just type in the other values after you clicked on the yes-button.
Logged
ka-la
Guest
« Reply #18 on: October 19, 2009, 03:09:09 pm »

Cool. Got hands on mind, anyway, downloading with IE didnt work, it gave me 1.4, but I tried with firefox and worked fine.
Logged
chiwou
Beginner
*
Posts: 44


View Profile
« Reply #19 on: October 19, 2009, 04:31:53 pm »

 Angry

still have this save bug, after I edited some images it wont show the save dialog
Logged
drakkar1969
Beginner
*
Posts: 59


View Profile
« Reply #20 on: October 19, 2009, 07:13:08 pm »

Awesome, thanks for the new release

Just one bug i noticed: when i import an image, the preview doesn't update (have to change position in the tree and go back to the modified part for the new image to display). And the undo button doesn't become active either
Logged
satukoro
Beta Tester
Dedicated Themer
*
Posts: 139


View Profile WWW
« Reply #21 on: October 19, 2009, 08:15:05 pm »

Sadly, I've lost my download link. But, I e-mailed Ave for another. Hopefully, I'll be able to make use of this amazing update.
Logged
chiwou
Beginner
*
Posts: 44


View Profile
« Reply #22 on: October 19, 2009, 10:06:09 pm »

I think I narrowed down, why this save bug thingy happens.

If I use the test button/or the "Use the VS" after saving, saving won't work anymore, this happens with AveStyler too, if I add and delete some VS to the list, I can't open the install dialog anymore *confused*

hope this helps Cheesy
Logged
CoLnE
Beginner
*
Posts: 77


View Profile
« Reply #23 on: October 19, 2009, 10:46:11 pm »

New versions are available at the original download link . I've just double-checked the file and it is version 1.5 for me.

still doesnt work ... can you please send me again the download link ?
my email is bad_colne@yahoo.com
Logged
vistatweak
Beginner
*
Posts: 34


View Profile
« Reply #24 on: October 20, 2009, 12:42:07 am »

Hi,

If i installed v 1.5.0.3 properly would it show in the about info as 1.5.0.3 ?    for now it still shows as 1.5.0.0

Thanks
Logged
AndreasV
Administrator
Dedicated Themer
*****
Posts: 158


View Profile
« Reply #25 on: October 20, 2009, 12:45:03 am »

The exe version should say 1.5.0.3, that's the leading version number.Right-click, properties, details.
Logged
vistatweak
Beginner
*
Posts: 34


View Profile
« Reply #26 on: October 20, 2009, 02:10:07 am »

OK it's all good thank you
Logged
ka-la
Guest
« Reply #27 on: October 20, 2009, 02:11:02 pm »

Problem I noticed under Vista, I got the win7 things has stopped working and after that VSB wont even work any more :O even if I restart. It doesnt start... going to win7 anyway.
Logged
CoLnE
Beginner
*
Posts: 77


View Profile
« Reply #28 on: October 21, 2009, 11:27:02 am »

damn ... i see that nobody wanna help me  Cry
Logged
K-Johnson
Beta Tester
Dedicated Themer
*
Posts: 275



View Profile WWW
« Reply #29 on: October 21, 2009, 11:55:44 am »

Send AndreasV a private message or e-mail and he should respond Smiley
Logged
bhast2
Beta Tester
Dedicated Themer
*
Posts: 177



View Profile WWW
« Reply #30 on: October 21, 2009, 03:29:29 pm »

Ok I found a problem
when I open a VS and change some images they don't show up right away i have to go to a different spot
example:
taskbar:1-change that image and it doesn't show up right away doesn't ask to change the image or resize the image
i click on taskbar:2 and than go back to taskbar:1 and the image is changed already.

the other problem:
I change some images run a test to see if they look right and than stop the test and try to save and it won't save
the same happens if i try to save if i am still in test mode too

so from what i see save is still not all the way fixed it was working great in 1.5.0.0 but om 1.5.0.3 it is broke again
Logged
ka-la
Guest
« Reply #31 on: October 21, 2009, 03:44:03 pm »

Yeah about the first problem its right. Dunno about the second.
Logged
K-Johnson
Beta Tester
Dedicated Themer
*
Posts: 275



View Profile WWW
« Reply #32 on: October 21, 2009, 05:38:13 pm »

Yeah, I hope AndreasV can fix those two bugs.  Especially the image one.  I wouldn't think it would be hard to, but what do I know.  Tongue
Logged
ka-la
Guest
« Reply #33 on: October 22, 2009, 02:32:05 pm »

What about the start button thing for win7?
Logged
cross
Beginner
*
Posts: 6


View Profile
« Reply #34 on: October 22, 2009, 07:15:31 pm »

I'm just curious...

Do we still have to start the program from the command line so it doesn't change the image numbers (so it will work when we apply it)?

i.e. C:\Program Files\AveApps\Windows Style Builder\VistaStyleBuilder.exe -noupdateimageids
Logged
cross
Beginner
*
Posts: 6


View Profile
« Reply #35 on: October 22, 2009, 07:19:50 pm »

What about the start button thing for win7?

I believe the start orb is located in a system file on Win7, not the theme file.  the same goes for the nav buttons.

You can thank MS for that. Smiley
Logged
ka-la
Guest
« Reply #36 on: October 22, 2009, 08:18:07 pm »

I believe the start orb is located in a system file on Win7, not the theme file.  the same goes for the nav buttons.

You can thank MS for that. Smiley

http://vistastylebuilder.com/forum/index.php?topic=585.0  read this and u understand what I mean.
Logged
Panda X
Administrator
Dedicated Helper
*****
Posts: 1627



View Profile
« Reply #37 on: October 22, 2009, 10:01:41 pm »

I'm just curious...

Do we still have to start the program from the command line so it doesn't change the image numbers (so it will work when we apply it)?

i.e. C:\Program Files\AveApps\Windows Style Builder\VistaStyleBuilder.exe -noupdateimageids
The only time you've had to do that is before 1.4 if you didn't change the firstImageId in the settings.
Logged
cross
Beginner
*
Posts: 6


View Profile
« Reply #38 on: October 22, 2009, 10:32:58 pm »

I didn't know the program had settings.  Where are the settings you are referring to?
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2106



View Profile
« Reply #39 on: October 23, 2009, 07:10:39 pm »

Your AppData/Roaming/Vsb/settings.ini.
If you can't find AppData tick "Show hidden files + folders" in your Folder Options.
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.12 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!