Vista Style Builder

   Home   Help Search Login Register  
Pages: [1] 2
  Print  
Author Topic: Build 10586  (Read 22174 times)
3am
Beta Tester
Dedicated Helper
*
Posts: 2092



View Profile
« on: November 06, 2015, 12:01:00 am »



Msstyle same as the last builds.

Likely final Threshold 2 or Fall Update. No expiration date, watermark etc
« Last Edit: November 06, 2015, 12:16:28 am by 3am » Logged
drakulaboy
Beginner
*
Posts: 61


View Profile
« Reply #1 on: November 07, 2015, 04:38:40 pm »

i'm on this build too, installed ultrauxthemepatcher
when i'm testing in WSB it's goes well, i can't find only this

 

searched in Explorer & Shell > Explorer > CommandModule but can't find any solution


and second problem is when i want to try the theme and move it to Themes folder i get this

 
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2092



View Profile
« Reply #2 on: November 07, 2015, 10:38:23 pm »

Everything is the usual for me:



See what happens when you don't use OldNewExplorer
Logged
drakulaboy
Beginner
*
Posts: 61


View Profile
« Reply #3 on: November 08, 2015, 10:19:36 am »

the commandmodule problem solved, but when i move my theme in Themes and want to apply it still nothing Sad
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2092



View Profile
« Reply #4 on: November 08, 2015, 01:50:38 pm »

I don't know Sad
« Last Edit: November 08, 2015, 10:23:18 pm by 3am » Logged
drakulaboy
Beginner
*
Posts: 61


View Profile
« Reply #5 on: November 08, 2015, 03:51:23 pm »

1. i done a File>New , then imported some properties from Steam theme, importing and testing original steam theme give's me a black screen, but i press Alt+F4 and close WSB and all is going back to normal
2. if i open it like this



 it's opening the themes settings

3. https://youtu.be/M3HoDiXvs10
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2092



View Profile
« Reply #6 on: November 08, 2015, 05:41:50 pm »

I've got another problem.

The msstyle tests, saves and the theme file applies (wallpaper, color and sounds change) but the msstyle stays default Aero.

I swear I've seen this happen before but I can't remember what caused it Huh?
Logged
drakulaboy
Beginner
*
Posts: 61


View Profile
« Reply #7 on: November 08, 2015, 05:45:42 pm »

exactly my problem, can't stand this white theme....i'm keeping WSB opened and testing Cheesy
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2092



View Profile
« Reply #8 on: November 08, 2015, 10:23:50 pm »

I rechecked everything over and over. Everything SHOULD be working right but isn't. I cannot apply the msstyle.

If you click "Use Visual Style" in the Save dialog it will apply but when you reboot it's gone again.

I don't know what's wrong. Does anybody else?
Logged
Jamie
Beginner
*
Posts: 87


Theme designer


View Profile WWW
« Reply #9 on: November 10, 2015, 05:45:46 am »

Damn, I just made all these visual styles for Windows 10 RTM, now they're all broken with the 'new' fall update. Sometimes I really hate Windows!  Love hate relationship going on I suppose.  Hopefully this gets resolved.  Really love customizing Windows 10.  For pity's sake why do they have to screw with the theme engine, it's like they're out to get us skinners I swear!  Angry

I'd really love to see a WindowsStyleBuilder for Windows 10.  I'd pay again for it's development.  It's about time we paid for an updated version anyhow, all the support that's been given since it's release.
« Last Edit: November 10, 2015, 06:16:53 am by Jamie » Logged
Jamie
Beginner
*
Posts: 87


Theme designer


View Profile WWW
« Reply #10 on: November 10, 2015, 10:19:35 am »

Got it working like you guys.  Not able to import my old themes.  Or apply the new ones without the help of StyleBuilder.  But here's hoping someone comes up with a patcher or workaround.

Metro X - Windows 10 - Fall Update http://fav.me/d9g6fxa

Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2092



View Profile
« Reply #11 on: November 10, 2015, 02:03:49 pm »

WSB is still working fine in TH2. You can edit everything that is in the msstyle and used by the system as always.

It's too bad TH1 themes aren't compatible with TH2 so far. I have tried a couple of fixes but nothing has worked. It's going to be rough having to port your TH1 themes manually. Hopefully somebody will find a solution.

It's really bad that you can't apply TH2 themes in TH2 through Personalization CPL. For some reason UxStyle and ULtraUXthemePatcher aren't working correctly at the moment. Hopefully that situation will get fixed.

You can still test, save and use a msstyle through WSB (though you have to re-save and re-use every time you re-boot which is a pain). The big problem is that anyone who doesn't have WSB won't be able to apply a theme.

Until these issues are fixed theming is going to be more difficult and people without WSB are going to be stuck with default Aero Sad
« Last Edit: November 10, 2015, 02:13:12 pm by 3am » Logged
Jamie
Beginner
*
Posts: 87


Theme designer


View Profile WWW
« Reply #12 on: November 10, 2015, 03:17:18 pm »

Yeah I would like to see a feature implemented if possible for an import Windows 8.1 and Windows RTM feature that would fix the issues.  That's kinda what I meant for a Windows 10 version of WSB.  I tried all kinds of things too, from trying different combinations of strings from the original aero .msstyle using Resource Hacker and importing to the Windows 10 RTM themes I've done.  Really an exercise in frustration after many failed attempts.  Also like you said hopefully UxStyle and ULtraUXthemePatcher fix the applying issue.
« Last Edit: November 10, 2015, 03:20:29 pm by Jamie » Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2092



View Profile
« Reply #13 on: November 10, 2015, 03:45:06 pm »

I tried stylehacking the new DWM stuff into 10240 and replacing the STREAM images but the images didn't look right and the msstyle wouldn't even test.

Attached is a list of everything that has changed since 10240 in case anybody needs it
Logged
Jamie
Beginner
*
Posts: 87


Theme designer


View Profile WWW
« Reply #14 on: November 10, 2015, 04:16:24 pm »

I noticed too there's no longer a shellstyle.dll included with default aero theme.  So when I apply a theme to test it it uses the custom shellstyle.dll I made for Metro X to get the dark side panel with white text but as soon as I quit stylebuilder it stops using the shellsyle so it revert back to black text on the sidepanel.  Hopefully this won't be an issue even if someone figures out how to apply themes through Personalization CPL.

If it comes down to it, I'm sure someone like Ave or somebody could come up with an application to apply themes using a similar engine WSB uses to apply them.  Without having to worry about the CPL option all together.  That'd be sweet!
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2092



View Profile
« Reply #15 on: November 10, 2015, 04:22:54 pm »

I have a shellstyle.dll in my Shell > NormalColor folder as usual. I attached the Shell folder if you need it.
Logged
Jamie
Beginner
*
Posts: 87


Theme designer


View Profile WWW
« Reply #16 on: November 10, 2015, 04:27:46 pm »

Hmm..that's so weird.  I must have moved it instead of copying it when I tried a few new themes.  Thanks mate.
Logged
gsw953
Beginner
*
Posts: 40


View Profile
« Reply #17 on: November 16, 2015, 04:11:58 am »

I am now able to load Gray10 from the Personalize window like normal.
I had to convert the .theme file to be a basic theme but it seems to be working
and using my msstyle.I did have to add [Control Panel\Colors] to the theme file
 to get some things to change, but it is a start at least
Edit
upon further testing i discovered the msstyle needs to be named aerolite
and put in the aero theme folder,so this probably isn't a good solution
« Last Edit: November 16, 2015, 05:07:42 am by gsw953 » Logged
Jamie
Beginner
*
Posts: 87


Theme designer


View Profile WWW
« Reply #18 on: November 16, 2015, 06:25:33 am »

Using gsw953's method I was able to update Metro X to apply without WSB on the November Update!

So we know it can be done.  Just a better solution needs to be found to select themes.  I'm super excited!  Cheesy

http://fav.me/d9dh3b2

Logged
Mr GRiM
Beta Tester
Dedicated Themer
*
Posts: 304


Master Theme Builder


View Profile
« Reply #19 on: November 16, 2015, 11:47:40 am »

Nice work guys, better then nothing, just means people will only have the choice of one theme at a time.
Logged
Jamie
Beginner
*
Posts: 87


Theme designer


View Profile WWW
« Reply #20 on: November 16, 2015, 09:04:04 pm »

I just tried putting my themes for Windows November Update that I'm creating into the regular places and they are working now after modifying the original aerolite.msstyles!

Now the themes are working fine (not the old RTM ones) but the new ones.  So all you have to do is replace the normal aerolite.msstyles with my modified version and any further installed ones should work fine!  Still bummed out that I have to redo all my themes but at least it's a start. Cheesy

*Update after logging out and back in it doesn't seem to be working! doh!
« Last Edit: November 16, 2015, 09:16:36 pm by Jamie » Logged
Mr GRiM
Beta Tester
Dedicated Themer
*
Posts: 304


Master Theme Builder


View Profile
« Reply #21 on: November 17, 2015, 01:02:54 am »

I just tried putting my themes for Windows November Update that I'm creating into the regular places and they are working now after modifying the original aerolite.msstyles!

Now the themes are working fine (not the old RTM ones) but the new ones.  So all you have to do is replace the normal aerolite.msstyles with my modified version and any further installed ones should work fine!  Still bummed out that I have to redo all my themes but at least it's a start. Cheesy

*Update after logging out and back in it doesn't seem to be working! doh!

You bugger, I was getting excited then until I read your update Sad
Logged
gsw953
Beginner
*
Posts: 40


View Profile
« Reply #22 on: November 17, 2015, 02:04:03 am »

I just tried putting my themes for Windows November Update that I'm creating into the regular places and they are working now after modifying the original aerolite.msstyles!

Now the themes are working fine (not the old RTM ones) but the new ones.  So all you have to do is replace the normal aerolite.msstyles with my modified version and any further installed ones should work fine!  Still bummed out that I have to redo all my themes but at least it's a start. Cheesy

*Update after logging out and back in it doesn't seem to be working! doh!

Jamie check your theme patcher,I can log out and restart and gray10 stays loaded
Logged
Jamie
Beginner
*
Posts: 87


Theme designer


View Profile WWW
« Reply #23 on: November 17, 2015, 05:13:09 pm »

It seems if I fiddle too much with the caption buttons I get an error applying the theme using the aerolite.msstyles hack for some reason.  The rest of the theme applies except for the caption bar and the caption buttons.  Must be how it's reading the DWM Window or Stream.  Works when I apply it using WSB though.  Will investigate further!
Logged
Mr GRiM
Beta Tester
Dedicated Themer
*
Posts: 304


Master Theme Builder


View Profile
« Reply #24 on: November 17, 2015, 07:02:23 pm »

It seems if I fiddle too much with the caption buttons I get an error applying the theme using the aerolite.msstyles hack for some reason.  The rest of the theme applies except for the caption bar and the caption buttons.  Must be how it's reading the DWM Window or Stream.  Works when I apply it using WSB though.  Will investigate further!

You might find with some themes you need to change the images from Windows & Caption Buttons > Aero > DWM Window > <65> to <92>

65 - 88 are the glyph images

89 - 92 are the min/max button images

I had to change these on one of my themes.

I just updated my class groups for the new parts, I have also integrated all of the other changes to Windows 10.



Feel free to download my updated class maps and groups, you will need to replace the ones in 8.1 for these to work.
« Last Edit: November 17, 2015, 07:19:30 pm by Mr GRiM » Logged
Jamie
Beginner
*
Posts: 87


Theme designer


View Profile WWW
« Reply #25 on: November 17, 2015, 07:19:17 pm »

You might find with some themes you need to change the images from Windows & Caption Buttons > Aero > DWM Window > <65> to <92>

65 - 88 are the glyph images

89 - 92 are the min/max button images

I had to change these on one of my themes.

Yeah I figured how to do that, still having issues without WSB to apply them though.   Weird.  Huh?
Logged
Mr GRiM
Beta Tester
Dedicated Themer
*
Posts: 304


Master Theme Builder


View Profile
« Reply #26 on: November 17, 2015, 07:20:37 pm »

Just edited my previous post with some updated class maps and class groups for Windows 10 TH2
Logged
Jamie
Beginner
*
Posts: 87


Theme designer


View Profile WWW
« Reply #27 on: November 17, 2015, 07:43:24 pm »

Just edited my previous post with some updated class maps and class groups for Windows 10 TH2

Sweet mate thanks!  Gonna check it out!
Logged
Jamie
Beginner
*
Posts: 87


Theme designer


View Profile WWW
« Reply #28 on: November 17, 2015, 09:42:53 pm »

There's a patch!  Verified working!  Sweetness!!!

http://www.cleodesktop.com/2015/11/install-uxthemepatcher-for-windows-10.html
Logged
Udzi
Beginner
*
Posts: 13


View Profile
« Reply #29 on: November 18, 2015, 02:26:00 pm »

Great to hear theres a patch!

Another Question: Was anybody able to put in a TaskBand Image and TaskbandItem? This changed with Windows 10 in a huge way...
Logged
gtjgtj
Beginner
*
Posts: 71


View Profile WWW
« Reply #30 on: November 18, 2015, 08:06:30 pm »

@Jamie: thank you for showing us a solution to patch the new Win 10 TH2. I 've read it...boah, that sound very comlicated  Huh?

If I create a msstyles file with WSB, can I use it in the new Windows TH2 build ?
How can I create a new .msstyles file with the WSB that works in TH2.
What is with the msstyles file which I yesterday stored with build 10240?
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2092



View Profile
« Reply #31 on: November 18, 2015, 11:55:42 pm »

deleted


« Last Edit: November 19, 2015, 02:16:46 pm by 3am » Logged
Jamie
Beginner
*
Posts: 87


Theme designer


View Profile WWW
« Reply #32 on: November 19, 2015, 02:22:29 am »

Yeah with Cu88's method you can create new Visual Styles from scratch.  They don't need to be basic.  Just fire up WSB and create a new theme and they apply just fine.  The old themes don't work anymore but at least until a better patcher comes out this method works.  Also the new updated class maps and groups from Mr Grimm work awesome as well.
Logged
gtjgtj
Beginner
*
Posts: 71


View Profile WWW
« Reply #33 on: November 19, 2015, 08:38:20 am »

Thank you all for your information. I'm better going to wait for a new UXTheme-patcher Huh?

@3am: Why you have to change the basic details in WSB? Is the new aerolite-style only a basic style without aero (like aero in Windows 7)?
If it's so I understand that I have to move all images which are currently in DWM Window to basic in the same thread of WSB. Is this correct?

If I understand it correct there is only one style in the new TH2 build (sorry, I don't load it) and only this style must be changed to aerolite.msstyles. Other parallel styles are not possible or non existent?

That means that you can't switch from one style to another with one click. Is that right? If yes it's not the best Idea by Microsoft, I think...
Logged
gsw953
Beginner
*
Posts: 40


View Profile
« Reply #34 on: November 19, 2015, 10:32:38 am »

According to gsw953:

1) You can theme the th2 msstyles in WSB as always

2) You must edit the Basic parts like Windows & Caption Buttons > Basic etc because you will be making a Basic theme

3) Rename your msstyles aerolite.msstyles

4) Replace the aerolite.msstyles in your aero folder with your aerolite.msstyles (keep a copy of the original)

5) Make sure your visual styles path in your .theme file is changed to [VisualStyles]
Path=%SystemRoot%\resources\themes\Aero\AeroLite.msstyles

6) Use the th2 shellstyle.dll


You can use CU88's method to apply it.

I haven't tried this. Many say it works and some say it doesn't. You will be patching the th2 theme files with the patched ones from th1


You can't use your th1 (Build 10240) msstyle in th2

If I'm wrong on any of this will you guys please correct me. Congrats to all of you Smiley




My method is kind of obsolete,I figured it out a couple of days before cu88 posted his patch.
The only advantage to using my method is that you can still use uxstyle  as your theme patcher
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2092



View Profile
« Reply #35 on: November 19, 2015, 01:36:19 pm »

Thanks for the corrections.

Yeah I got the aerolite thing from your comment and when I looked at Jamie's Metro X. I didn't realize that was kind of obsolete now with cu88's manual patch solution. I see there's no aerolite in Jamie's Void for instance. I like keeping UxStyle though

I deleted my post and have left the discussion before I confuse anybody else about what's going on.
« Last Edit: November 19, 2015, 02:18:47 pm by 3am » Logged
andyjessy
Beginner
*
Posts: 28


View Profile
« Reply #36 on: November 19, 2015, 07:02:37 pm »

Hey guys, but where is cu88's patch? Thanks
Logged
andyjessy
Beginner
*
Posts: 28


View Profile
« Reply #37 on: November 20, 2015, 12:01:39 am »

Ok found it, but I have another urgent problem, can someone please post the original aero.msstyle please? It has disappeared from my aero folder. Thanks
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2092



View Profile
« Reply #38 on: November 20, 2015, 12:12:25 am »

Attached
Logged
andyjessy
Beginner
*
Posts: 28


View Profile
« Reply #39 on: November 20, 2015, 12:16:28 am »

Thanks Smiley
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.12 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!