Vista Style Builder

   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Start Menu renders wrong color occasionally  (Read 6614 times)
xyl360
Beginner
*
Posts: 34


View Profile
« on: January 07, 2015, 12:41:05 pm »

I'm using a custom theme with the stylehack which renders the entire Start Menu transparent on the left side, however for some reason when opening the Start Menu on occasion, usually the first time after boot or restarting explorer.exe, but also occasionally other times as well, the lower third of it is rendered semi-opaque filled with the color set via the 'Window Color' controls in 'Window Color and Appearance' in the desktop control panel.  The color configured for my theme doesn't seem to matter, it simply renders it with whatever color Windows is configured to use.

Is anyone familiar with this behavior and does anyone have any ideas on how to correct it so that it will always render correctly rather than filling with the Aero window color?
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2259



View Profile
« Reply #1 on: January 08, 2015, 02:14:59 pm »

Not sure. Attach the msstyles and I'll take a look
Logged
xyl360
Beginner
*
Posts: 34


View Profile
« Reply #2 on: January 08, 2015, 05:29:01 pm »

Sure, here you are.
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2259



View Profile
« Reply #3 on: January 08, 2015, 10:43:19 pm »

I don't know. Try this. Maybe it'll work
Logged
xyl360
Beginner
*
Posts: 34


View Profile
« Reply #4 on: January 08, 2015, 10:59:51 pm »

That seems to have worked, however I guess it does so by setting the transparency of active windows to maximum which is unfortunately not what I want (I set the color to a deep purple tone normally, with the color intensity set to max as well as max saturation).

If you think you can fix it, here's a copy of my latest.  If not that's OK, I'll just have to live with it.  I guess it might just be a quirk with Windows when using the transparent Start Menu stylehack.
Logged
3am
Beta Tester
Dedicated Helper
*
Posts: 2259



View Profile
« Reply #5 on: January 08, 2015, 11:37:55 pm »

Give this a shot. Otherwise I'm out of ideas.
Logged
xyl360
Beginner
*
Posts: 34


View Profile
« Reply #6 on: January 09, 2015, 12:42:30 am »

Nope, no change from my original one unfortunately.  The issue still happens.

It's OK, I appreciate you trying to fix it for me.  I guess there's just something wonky with Windows that causes it to occasionally render it that way when using a transparent programs list in the Start Menu.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.12 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!