Vista Style Builder

   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Stable version, avoid black screen, etc...  (Read 10454 times)
Alpha Pixel
Beginner
*
Posts: 9



View Profile
« on: September 17, 2014, 12:31:09 pm »

Hi there,

So, I had a black screen issue yesterday, Windows refused to start again, I could see the pointer when I moved it but nothing else. And on top of that, Windows screwed up the recovery, so I was not able to go back in time. So, after 2 hours going in circle, I simply format the Windows/software partition and installed everything again...
But of course this is something I'd like to avoid as much as possible, spending hours installing and downloading everything again, including loosing some of the personal preferences inside some softwares like Photoshop is not something I want everyday Huh? especially on an SSD where you try to avoid writing ^^'

Now, I'm aware this can come from different things, WSB, depending on the version and how we use it, or UltraUXThemePatcher, or I don't know. And that's my point. I'm not sure where that came from but I sure would like to avoid it in the future and make things more stable at every level, so I'd like to gather informations in one post (I haven't seen one until now, so if it already exist then I'm terribly sorry ^^), and hopefully help others in the process.

Until now I learned to "never click "Use the Visual Style" in 8. I let WSB compile it and then apply it by clicking my .theme file or through Personalization." from 3am.

Also, in case something like that happen, I always have a Ubuntu (or Elementary) on a usb stick in order to access my files. But it there some way, some files to delete, or to replace with a backup, or I don't know... that could help Windows start again? Maybe WSB creates a .theme somewhere which is the cause of the problem, and deleting it would help Windows starts with Aero?

Last time I had the problem, I had to use the recovery and go back to the time before WSB was even installed and it worked pretty well and I didn't lose much.
But again, yesterday for an unknown reason, the first time I tried it didn't work, so I tried again to go further in the past, but then Windows recovery couldn't find anything anymore... Cry
I also remember having the issue some time ago, but it was a problem between a Windows update and UxStyle. And I think the only thing I did then was to move my personal .theme, and Windows was able to start using Aero as default.

Finally, is there a version of WSB that is known to be more stable than others ? I'm not sure that this exist for Windows 8.1.1, but you never know ^^

Of course if there's anything that could help in this topic, please share your knowledge and experience, and how you fixed the problem if you encountered it.
Logged
Panda X
Administrator
Dedicated Helper
*****
Posts: 1627



View Profile
« Reply #1 on: September 17, 2014, 09:55:14 pm »

It's not WSB that causes it, it's a bug in winlogon. Whether or not you apply via WSB or with a .theme file is irrelevant as they both apply themes the same way, so it can still happen. Sometimes it can happen just based on where you saved the file, which is why I always either use the desktop or %programdata%
Logged
JMB
Dedicated Themer
*
Posts: 135


aka YourNumbr1Fan


View Profile
« Reply #2 on: September 17, 2014, 11:10:43 pm »

I know from hard experience that UltraUXThemePatcher has been the culprit of 99% of my past black-screens. It happened like 3 times, when I used to use that one. Right now I'm using the latest version of UXTheme Multi-Patcher. It, rather than patching your system-files directly, runs as a service and loads with the system memory I think...and from what I understand, is a lot safer.

 
Logged
Alpha Pixel
Beginner
*
Posts: 9



View Profile
« Reply #3 on: September 19, 2014, 02:49:57 pm »

Panda X, I always save my theme in the default windows folder (...\Windows\Resources\Themes).
On my previous black screen, all I did was a recovery before WSB was installed, yet UltraUX was still installed and the last version of my theme too, and then Windows started normally again. That's why I strongly assumed it came from WSB.

My WSB also blank every 20-30mn depending on how active I am with it (the elements in the window become white when I hover over them, I can't do anything, I can just kill the process). And sometimes it just crashes out of nowhere when I try to test. I can then restart, do the exact same changes, test again, and it will work. And this is why I call for stability ^^

YourNumbr1Fan, I used UXTheme before UltraUX, but at some point it had a compatibility issue with a Windows update, that's why I changed to UltraUX, but I'll give it another shot.

Thanks for the feedback.
Logged
Alpha Pixel
Beginner
*
Posts: 9



View Profile
« Reply #4 on: September 20, 2014, 02:39:50 pm »

Oh I just find out that I wasn't using UXTheme before but UXStyle... I mingled the UXsomething Tongue
Logged
drakulaboy
Beginner
*
Posts: 61


View Profile
« Reply #5 on: September 20, 2014, 08:29:42 pm »

so what is good to use UXTheme Multi-Patcher 12.0 or UltraUXThemePatcher ?
i'm using UltraUXThemePatcher and got a few black screens
Logged
Panda X
Administrator
Dedicated Helper
*****
Posts: 1627



View Profile
« Reply #6 on: September 20, 2014, 09:16:05 pm »

UxThemePatcher also doesn't cause the black screens, it's winlogon getting stuck in an infinite loop.
Logged
Mr GRiM
Beta Tester
Dedicated Themer
*
Posts: 304


Master Theme Builder


View Profile
« Reply #7 on: September 21, 2014, 12:50:42 am »

Uxstyle doesn't patch any files and runs as a service to bypass the theme digital signature and should not cause any black screen bug, I have never had a problem with the black screen bug since I started using it when it first became available, your problem would probably be from saving your theme and applying it from outside the C:\Windows\Resources\Themes directory or you are mistaken and have used another patching program that does rely on patching system files to allow custom themes.

You are correct about needing a more stable WSB though, this latest version seems to crash far more often, instant closes at any random time while doing something, allot of the times it will also destroy the test msstyles as well giving you no backup if you have not saved recently, also the other problem with WSB controls going white and freezing is still a big problem and happens just as often as the instant close bug I am now seeing but at least with that bug that requires you to kill WSB through Task Manager you are still able to retrieve your latest changes in the C:\ProgramData\Windows Style Builder\Testing directory.
Logged
Panda X
Administrator
Dedicated Helper
*****
Posts: 1627



View Profile
« Reply #8 on: September 21, 2014, 02:44:10 am »

This build doesn't prevent a blackscreen, but it'll try to recover from it: http://vistastylebuilder.com/forum/index.php?topic=2130.0

It suspends WinLogon, checks if DWM is running, if not applies Aero and resumes WinLogon (which itself will restart DWM).
« Last Edit: September 21, 2014, 03:26:19 am by Panda X » Logged
Alpha Pixel
Beginner
*
Posts: 9



View Profile
« Reply #9 on: September 21, 2014, 03:50:01 pm »

Thanks for the feedback

Uxstyle doesn't patch any files and runs as a service to bypass the theme digital signature and should not cause any black screen bug, I have never had a problem with the black screen bug since I started using it when it first became available, your problem would probably be from saving your theme and applying it from outside the C:\Windows\Resources\Themes directory or you are mistaken and have used another patching program that does rely on patching system files to allow custom themes.
you are still able to retrieve your latest changes in the C:\ProgramData\Windows Style Builder\Testing directory.

I wasn't using Uxstyle, I was using UltraUXthemePatcher.
I only used Uxstyle more than a year ago but I was also not using WSB at that time, and I changed my hard drive in the meantime, and only used UltraUXthemepatcher after that.

I have never installed an .msstyle out of the Windows\Resources\Theme folder. But aren't you saying that WSB creates a backup file outside of this folder when testing ? Couldn't that be the reason of the problem ? After some crash of WSB, maybe Windows 8 starts using the theme inside that tesitng folder instead, and that would cause the black screen bug ? I don't know, I'm just speculating based on everything I read on the subject ^^
On my last black screen, using my Ubuntu usb stick, I deleted all I could find of WSB from my hard drive but I did not touch the C:\ProgramData\Windows Style Builder\Testing directory because I wasn't aware of that... but maybe Windows would have tried to use Aero again if I had deleted all that too ?
Logged
Mr GRiM
Beta Tester
Dedicated Themer
*
Posts: 304


Master Theme Builder


View Profile
« Reply #10 on: September 21, 2014, 06:43:10 pm »

That is a possibility because I have had WSB crash many times when testing and it continues to run the test theme after the crash, I have always changed back to another theme though before I start testing again, personally I never work on my themes in the theme directory, I have always worked with them in folders on the desktop and I honestly would prefer it if there was an option to disable the 2nd prompt after every save to use the theme now, I never want to use the theme now, I will create my complete theme and .theme file and then place it in the theme directory when I am done and apply it from the personalization menu.
Logged
Alpha Pixel
Beginner
*
Posts: 9



View Profile
« Reply #11 on: September 22, 2014, 10:55:04 pm »

Quick update, after some small tests, WSB had not crashed once since my reinstall (I don't have the time to work a lot with it though), and yet there was 5 msstyles in C:\ProgramData\Windows Style Builder\Testing ... So I can't imagine how it was before ^^
Logged
Panda X
Administrator
Dedicated Helper
*****
Posts: 1627



View Profile
« Reply #12 on: September 22, 2014, 11:01:27 pm »

You can clear out the testing folder, it's supposed to automatically, but can't if it crashes.
Logged
Alpha Pixel
Beginner
*
Posts: 9



View Profile
« Reply #13 on: September 23, 2014, 06:15:16 am »

I'll watch for it now, but again, WSB hasn't crashed, not even once, that's why I reported that.
I only opened 3 themes (including Aero), test them, do some small modifications on only 1, but 5 msstyles were made in that folder. And I only use WSB normally, by changing and testing the theme, saving, and closing.

I've done it again during the evening, I've only opened one theme, again, simply modifying testing, saving, and closing WSB, and I now have 6 msstyles based on my theme (they all begins with the name of my theme (Project_101). And WSB did not crash, again, and was closed normally.

Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.12 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!